Aide
>
Réponse

Sur quel(s) navigateur(s) Shelblock peut-il être utilisé ?

Shelblock peut être utilisé sur tous les navigateurs du marché quelles que soient les versions (Chrome, Safari, Firefox, Opera, Internet Explorer, Edge, etc.).

Pour l'installer, vous devez seulement utiliser une version de Windows récente (7, 8, 8.1 ou 10).

< Retour